Back to overview
Degraded
Increased error rates
Jun 18, 2026 at 2:15pm UTC
Affected services
api.postgrid.com - Print & Mail API
Resolved
Jun 18, 2026 at 3:30pm UTC
Issue causing increased error rates has been resolved.
Affected services
Created
Jun 18, 2026 at 2:15pm UTC
Print & mail API calls are failing at a high rate with 5xx errors.
Affected services