Back to overview
Downtime

All products unavailable

Apr 24, 2026 at 9:29pm UTC
Affected services
api.postgrid.com - Print & Mail API
api.postgrid.com - Address Verification API
app.postgrid.com - Address Verification Dashboard
dashboard.postgrid.com - Print & Mail Dashboard

Resolved
Apr 24, 2026 at 11:40pm UTC

Requests should return to normal.

Updated
Apr 24, 2026 at 9:47pm UTC

Our managed database provider has confirmed that they have capacity issues on their end causing this outage to be extended. We are continuing to work with their support team to bring our products back online.

Created
Apr 24, 2026 at 9:29pm UTC

Our managed database provider has had a failure in their systems. We are in touch with their support representatives to restore our service imminently.