Back to overview
Degraded

API and Dashboard latencies elevated

Feb 02 at 12:46pm EST
Affected services
api.postgrid.com - Print & Mail API
api.postgrid.com - Address Verification API
app.postgrid.com - Address Verification Dashboard
dashboard.postgrid.com - Print & Mail Dashboard

Resolved
Feb 02 at 02:43pm EST

Latencies have returned to normal and performance has been steady for ~1 hour.

Created
Feb 02 at 12:46pm EST

We're observing higher latencies across the board. We've already deployed a fix and performance issues should be resolved within an hour.