Back to overview
Degraded

API and Dashboard latencies elevated

Jan 14 at 12:49pm EST
Affected services
api.postgrid.com - Print & Mail API
api.postgrid.com - Address Verification API
dashboard.postgrid.com - Print & Mail Dashboard

Resolved
Jan 14 at 02:26pm EST

We've resolved the underlying issue and latencies have returned to normal.

Updated
Jan 14 at 01:27pm EST

We have identified the root cause of the degradation and are deploying a fix at the moment. Performance should return to normal within the next hour.

Created
Jan 14 at 12:49pm EST

We are observing increased latencies for API calls and elevated dashboard load times. We are working on a resolution and will provide an update within an hour.