Back to overview
Degraded

Performance Degradation in AV API

Feb 07 at 01:05pm EST
Affected services
api.postgrid.com - Address Verification API

Resolved
Feb 08 at 01:09pm EST

AV performance should now be stable.

Updated
Feb 08 at 01:12am EST

We've scaled up our data services to resolve performance issues. Most verification API calls should now be processed without timeouts.

Created
Feb 07 at 01:05pm EST

We're investigating reduced performance in our address verification endpoints. We recommend limiting batch verification API call payloads to 500 or fewer addresses at this time.