Back to overview
Degraded

Contact creation issue in PM - Update

Feb 01 at 04:04pm EST
Affected services
api.postgrid.com - Print & Mail API

Resolved
Feb 01 at 04:12pm EST

This is now resolved.

Created
Feb 01 at 04:04pm EST

We've identified the issue with contact creation and are deploying a fix. Should be live within the next 10-15 minutes.